Autor Tema: BennuGD packager  (Leído 101118 veces)

josebita

  • Administrator
  • *****
  • Mensajes: 4039
  • Karma: 257
    • BennuGD Mobile Worklog
Re:BennuGD packager
« Respuesta #225 en: Agosto 26, 2013, 02:40:38 pm »
Bueno, he subido una "actualización" del packager. Debería arreglar fallos de compatibilidad con Android 2.3
El port de Bennu sigue siendo el mismo que en la anterior compilación del packager.
https://code.google.com/p/bennugd-packager/downloads/detail?name=packager-win32-20130826.7z

Sigo recomendando que para compilar utiliceis ANT a mano. Echadle un ojo al repo de pixjuegos para ver cómo lo hacen, porque es la mejor forma.

Ruter106

  • Newbie
  • *
  • Mensajes: 42
  • Karma: 1
Re:BennuGD packager
« Respuesta #226 en: Marzo 09, 2014, 11:08:06 am »
Sería interesante que además de poder instalar el APK generado en un AVD o en un dispositivo y guardar el APK, se pudiese de alguna forma acceder al proyecto generado para poder hacer retoques en la versión empaquetada por la herramienta.

No sé si suena descabellado la propuesta, pero actualmente el proyecto sólo es accesible desde la carpeta de temporales, si se produce algún error en el proceso.

No obstante un gran trabajo Josebita!!!  ;)

Aprovecho para hacer una consulta y es que cuando empaqueto el proyecto en Landscape, el juego no arranca. No he tenido tiempo de mirarlo demasiado, pero supongo que podría ser por tema de resolución.

master

  • Full Member
  • ***
  • Mensajes: 123
  • Karma: 3
Re:BennuGD packager
« Respuesta #227 en: Octubre 31, 2014, 05:17:51 am »
Hola  todos, estaba empezando con esto de android, pero al momento de usar el packager me manda esto en consola, veo que a varios ya les pasó...

Código: [Seleccionar]
Total time: 0 seconds
Traceback (most recent call last):
  File "/usr/share/bennugd-packager/packager.py", line 286, in package
    sys.stdout.write('Admobs Ads SDK: %s\n' % admobjar)
UnboundLocalError: local variable 'admobjar' referenced before assignment

bajé el packager del ppa, estoy en Debian de 32 bits.
otra cosa, cuando tildeo la opción "Show AdMob ads" y escribo numeros en el campo, no me salta el error, pero no me crea el apk, y me manda lo siguiente:

Código: [Seleccionar]
Looking for AdMob Ads SDK
Admobs Ads SDK: /home/fenixero/Descargas/desarrollo/android-sdk-linux/extras/google/admob_ads_sdk/GoogleAdMobAdsSdk-6.4.1.jar
Packaging for: Android
Workdir: /tmp/bgdp_8cb30394-60b9-11e4-a3cc-6466b31c8f6c
Buildfile: /tmp/bgdp_8cb30394-60b9-11e4-a3cc-6466b31c8f6c/build.xml

-set-mode-check:

-set-debug-files:

-check-env:
 [checkenv] Android SDK Tools Revision 23.0.5
 [checkenv] Installed at /home/fenixero/Descargas/desarrollo/android-sdk-linux

-setup:
     [echo] Project Name: SDLApp
  [gettype] Project Type: Application

-set-debug-mode:

-debug-obfuscation-check:

-pre-build:

-build-setup:
[getbuildtools] Using latest Build Tools: 21.0.2
     [echo] Resolving Build Target for SDLApp...
[gettarget] Project Target:   Android 4.1.2
[gettarget] API level:        16

BUILD FAILED
/home/fenixero/Descargas/desarrollo/android-sdk-linux/tools/ant/build.xml:542: Application package 'test and te coll' must have a minimum of 2 segments.

ya instalé el Google Ads SDK

No puedo descargar la actualización del packager-win32-20130826.7z l, La versión en google code me aparece como "Deprecated"

Código: [Seleccionar]
The requested URL /p/bennugd-packager/downloads/detail?name=packager-win32-20130826.7z was not found on this server.

master

  • Full Member
  • ***
  • Mensajes: 123
  • Karma: 3
Re:BennuGD packager
« Respuesta #228 en: Octubre 31, 2014, 03:39:10 pm »
Me autorespondo parcialmente:

Respecto a lo primero, en windows usé el devBennu que Erkosone subió con sus videotutoriales de android y todo bien.

Pero en debian sigo con el mismo problema del error. Este deja de aparecer si se tildea la opcion "Show AdMob ads" y se escribe algo en el campo, el apk generado corre correctamente.

Del segundo error, en el campo descripción, se tiene que seguir una estructura, como "com.nombredeempresa.nombredejuego", no lo escribía así y me saltaba el error.

Abría que ver que pasa con lo del primer error, sino, pues no se si podrá trabajar correctamente fuera de windows si no se posee el ID del Admobs Ads.
« última modificación: Octubre 31, 2014, 10:35:34 pm por master »

warrior_rockk

  • Full Member
  • ***
  • Mensajes: 227
  • Karma: 8
Re:BennuGD packager
« Respuesta #229 en: Agosto 30, 2015, 11:31:15 am »
¿Alguien tiene ésa última descarga que colgó Josebita? La de 20130826. El enlace ya ha sido retirado por Google Code...