Autor Tema: Intentando compilar BennuGD desde los fuentes, error en ./build-linux.sh  (Leído 316 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Conectado Futu-block

  • Hero Member
  • *****
  • Mensajes: 2624
  • Karma: 33
  • Sexo: Masculino
  • Superviviente marciano
    • Ver Perfil
    • futublock
Re:Intentando compilar BennuGD desde los fuentes, error en ./build-linux.sh
« Respuesta #15 en: Octubre 25, 2017, 02:30:21 pm »
muy bien, me alegro



Conectado SplinterGU

  • Hero Member
  • *****
  • Mensajes: 12517
  • Karma: 369
  • Sexo: Masculino
    • Ver Perfil
Re:Intentando compilar BennuGD desde los fuentes, error en ./build-linux.sh
« Respuesta #16 en: Octubre 25, 2017, 08:24:50 pm »
Bueno, la buena noticia es que de alguna manera compiló. Así que por el momento la agriculturá tendrá que esperar  :P

Con respecto a lo que dijiste, Splinter: Comprobé y tengo ambas librerias instaladas (con la arquitectura :i386, todas), y una tercera openssl tambien, pero que creo que esa no tiene nada que ver. Muestro el resultado de algunos comandos:
Código: [Seleccionar]
$ sudo apt-get install libssl1.0.0:i386 libssl-dev:i386
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
libssl-dev:i386 ya está en su versión más reciente (1.0.2g-1ubuntu4.8).
libssl1.0.0:i386 ya está en su versión más reciente (1.0.2g-1ubuntu4.8).
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 4 no actualizados.

$ dpkg -L libssl1.0.0:i386|grep so
/lib/i386-linux-gnu/libcrypto.so.1.0.0
/lib/i386-linux-gnu/libssl.so.1.0.0
/usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libaep.so
/usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libchil.so
/usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libatalla.so
/usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libsureware.so
/usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libpadlock.so
/usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libgmp.so
/usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libcswift.so
/usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libcapi.so
/usr/lib/i386-linux-gnu/openssl-1.0.0/engines/lib4758cca.so
/usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libgost.so
/usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libnuron.so
/usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libubsec.so

$ dpkg -L libssl-dev:i386|grep so
/usr/include/openssl/dso.h
/usr/lib/i386-linux-gnu/libssl.so
/usr/lib/i386-linux-gnu/libcrypto.so


Con respecto a lo que dijiste, daltomi, una vez que ejecuté el comando que pasaste, tuve el mismo problema con SDL, hice el cambio, y ahi finalmente compiló y creó los binarios!! gracias!!, pero en el log habia una advertencia de que no iba a ser un binario portable (supongo que por haberle especificado las rutas). Pero despues haciendo ldd (como hizo splinter) a la libreria, me da las mismas mismas rutas.

Código: [Seleccionar]
$ ldd bin/i386-linux-gnu/libbgdrtm.so
linux-gate.so.1 =>  (0xf77fa000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf75ef000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf75ea000)
libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0xf75ce000)
libcrypto.so.1.0.0 => /lib/i386-linux-gnu/libcrypto.so.1.0.0 (0xf73e2000)
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf738d000)
/lib/ld-linux.so.2 (0x565d1000)

Lo raro es que no instalé de ninguna manera rara las librerias como para que no las encuentre. No tengo idea que pueda llegar a ser lo que hace que no funcione de la manera normal. Si tienen alguna sugerencia más, soy todo oidos.


EDIT: ya se puede ver el PRIMER BUILD EXITOSO en Travis: https://travis-ci.org/tehuel/bennugd/builds/292844565  ;D

algo esta fallando, no deberia darte ese mensaje de que no es portable, eso pasa cuando no encuentra alguna .so...

te sugiero empezar de cero con la oficial nuevamente... lo que tenes que hacer es instalar las libs que te dije en mi ultimo mensaje...

libssl-1.0.0:i386 y libssl-dev:i386, la openssl no es necesario

y ejecuntes el ./build-linux.sh release
Download Lastest BennuGD Release: http://www.bennugd.org/node/2