Autor Tema: Windows Vista+FlameBird=no se puede usar...  (Leído 6580 veces)

kim-elet-o

  • Sr. Member
  • ****
  • Mensajes: 397
  • Karma: 8
Re: Windows Vista+FlameBird=no se puede usar...
« Respuesta #15 en: Agosto 26, 2008, 07:26:45 am »
yo deje el flamebird (a mi pesar), por que cuando mi prg paso de 64k, el flamebird se cerraba cada vez que intentaba cargar mi prg, entonces lei en un post del divsite, sobre las virtudes del ultraedit y me cambie a este, luego le puse el fichero del resaltado y coloracion de la sintaxis del fenix, y soy el hombre mas feliz del mundo, incluso con el ultraedit he ganado un editor en hexadecimal para ficheros no de texto, de lo mas util para comprobar que mis programas graban bien sus datos, podia pedir mas pero de momento estoy satisfecho.

|/
|\im-elet-o el yayo programador.

osk

  • Hero Member
  • *****
  • Mensajes: 516
  • Karma: 52
Re: Windows Vista+FlameBird=no se puede usar...
« Respuesta #16 en: Agosto 26, 2008, 03:58:23 pm »
Ya. Pero es que el Ultraedit no es free, si no lo he visto mal en su web. Cuesta 50 dólares. Y yo (es una cuestión personal) paso de pagar por un editor. Y de piratear también, más que nada por pereza.

SplinterGU

  • Hero Member
  • *****
  • Mensajes: 12837
  • Karma: 377
Re: Windows Vista+FlameBird=no se puede usar...
« Respuesta #17 en: Agosto 26, 2008, 04:25:04 pm »
Creo que es uno de los pocos productos donde el costo es bien merecido...
Tanto el Ultraedit como el Total Commander, tienen bien ganados el valor de su licencia.

Tenes el crimson editor que tiene algunas caracteristicas similares y es free.
Download Lastest BennuGD Release: http://www.bennugd.org/node/2

osk

  • Hero Member
  • *****
  • Mensajes: 516
  • Karma: 52
Re: Windows Vista+FlameBird=no se puede usar...
« Respuesta #18 en: Agosto 27, 2008, 01:04:39 am »
Hola chicos, no quiero fastidiar ni mucho menos (avisadme si lo consigo) pero no sé si la elección del Crimson Editor como editor por defecto del BennuPack es la decisión más acertada...Más que nada porque no se actualiza desde el 2004 y eso se nota en el aspecto un poco tosco de la interfaz...Y es freeware, que no libre.
¿Habéis probado el Notepad++: http://notepad-plus.sourceforge.net? Es GPL, aunque sólo sirve para Windows (tratándose del BennuPack no habría problema,no?). Pero hay muchos más que son multiplataforma (sería genial unificar y usar una herramienta para todosl...): SciTE (http://www.scintilla.org/SciTE.html), Jedit (http://www.jedit.org), etc, etc.Posibilidades hay infinitas, y precisamente por eso, haber escogido un editor no libre que no se actualiza de hace 4 años no sé si es una buena estrategia de futuro. Pero vaya, para gustos, colores.

SplinterGU

  • Hero Member
  • *****
  • Mensajes: 12837
  • Karma: 377
Re: Windows Vista+FlameBird=no se puede usar...
« Respuesta #19 en: Agosto 27, 2008, 01:09:12 am »
osk, si, probe el notepad++ pero lo descarte, no se por cual motivo, lo voy a volver a mirar, por los motivos que crei recordar ahora no son...
si vos sabes manejarlo y te animas, te invito a armar los archivos de configuracion usando los templates de aca http://forum.bennugd.org/index.php?topic=165.msg1628#new y compartirlos con todos nosotros...
« última modificación: Agosto 27, 2008, 01:13:02 am por SplinterGU »
Download Lastest BennuGD Release: http://www.bennugd.org/node/2

SplinterGU

  • Hero Member
  • *****
  • Mensajes: 12837
  • Karma: 377
Re: Windows Vista+FlameBird=no se puede usar...
« Respuesta #20 en: Agosto 27, 2008, 01:32:49 am »
Bueno, si, volvi a probarlo, y a modificar (agregar la sintaxis de bennu) en los archivos de configuracion y no los toma, solo toma lo que estan metidos (supongo que por codigo), lamentablemente a pesar de que en la pagina dice que se pueden agregar archivos definidos por el usuario esto no es posible...
Bennu aparece en la lista si voy a configuracion, pero no detecta los archivos que abro como tales, y tampoco me deja seleccionar manualmente la sintaxis bennu, por eso no lo inclui como un IDE valido...
aclaracion que no tengo nada que ver con bennupack.

Si vos logras hacerlo, agradeceremos que lo compartas...
« última modificación: Agosto 27, 2008, 01:34:47 am por SplinterGU »
Download Lastest BennuGD Release: http://www.bennugd.org/node/2

osk

  • Hero Member
  • *****
  • Mensajes: 516
  • Karma: 52
Re: Windows Vista+FlameBird=no se puede usar...
« Respuesta #21 en: Agosto 27, 2008, 07:16:42 pm »
Ok. Veré lo que puedo hacer.

SplinterGU

  • Hero Member
  • *****
  • Mensajes: 12837
  • Karma: 377
Re: Windows Vista+FlameBird=no se puede usar...
« Respuesta #22 en: Agosto 27, 2008, 07:29:14 pm »
buenisimo, gracias.
Download Lastest BennuGD Release: http://www.bennugd.org/node/2

l1nk3rn3l

  • Hero Member
  • *****
  • Mensajes: 2002
  • Karma: 257
Re: Windows Vista+FlameBird=no se puede usar...
« Respuesta #23 en: Agosto 27, 2008, 07:37:31 pm »
el tema es interesante,

escoger ese para el bennupack fue algo trivial, al azar
entre varios disponibles,
ya que se requeria algo pronto para poder usar bennu
mas comodamente en vista, asi que opte por ese,
(aqui deberian aparecer las groserias que dije de flamebird ·$%$·%$·%$%)
flamebird es un buen proyecto, su defecto es que es muy vistoso
pero nada funcional a la larga, merefiero a que tiene muchas
dependencias innecesarias.. que al final crean errores de todo tipo
cuando se usa.

y bueno esa clase de sugerencias hacen que las cosas
mejoren asi que el proximo saldra con un IDE
multiplataforma y de codigo abierto.

blostec

  • Hero Member
  • *****
  • Mensajes: 746
  • Karma: 20
Re: Windows Vista+FlameBird=no se puede usar...
« Respuesta #24 en: Agosto 27, 2008, 09:03:03 pm »
y bueno esa clase de sugerencias hacen que las cosas
mejoren asi que el proximo saldra con un IDE
multiplataforma y de codigo abierto.

Se puede saber cual sera el nuevo ide?

No conocía el Crimson pero por lo poco que he probado esta bastante bien.


ultrakobra

  • Newbie
  • *
  • Mensajes: 34
  • Karma: 0
Re: Windows Vista+FlameBird=no se puede usar...
« Respuesta #25 en: Agosto 27, 2008, 10:11:15 pm »
Me alegro de que mi problema haya dado pie a un cambio a favor de esta gran herramienta de desarrollo.
Larga vida a  Bennu ! jeje
He's gonna take you back to the back,to play the shitty games that suck ass ♪

HaCkZJuaNN

  • Full Member
  • ***
  • Mensajes: 179
  • Karma: 5
Re: Windows Vista+FlameBird=no se puede usar...
« Respuesta #26 en: Agosto 28, 2008, 12:18:55 am »
Yo utilizo crimson desde hace casi 1 año y la verdad que no me da ningún problema, y me da de sobra lo que quiero: me colorea la sintaxis, me permite compilar y ejecutar rápidamente, y funciona bien, no se ralentiza con códigos largos, tiene funciones de búsqueda bastante buenas... lo único que me gustaría es poder hacer los maps y fpgs desde el crimson también, pero tras estudiarlo bastante a fondo parece que es imposible.