Autor Tema: Problemas con la compilación en Ubuntu 64bits  (Leído 1474 veces)

Yawin

  • Hero Member
  • *****
  • Mensajes: 1088
  • Karma: 44
  • La primera persona que ha "demosceneado" en Bennu.
Problemas con la compilación en Ubuntu 64bits
« en: Enero 11, 2013, 10:48:28 am »
Hola a todos. Aunque por los estudios tengo muy abandonada esta comunidad, de vez en cuando meto algo de mano a Bennu para no olvidarlo. La cosa es que acabo de instalarlo en Ubuntu Studio y la compilación me saca un log tal que así:

Código: [Seleccionar]
BGDC 1.0.0 (Nov 21 2012 18:57:53)
Bennu Game Development Compiler

Copyright (c) 2006-2012 SplinterGU (Fenix/BennuGD)
Copyright (c) 2002-2006 Fenix Team (Fenix)
Copyright (c) 1999-2002 Jos� Luis Cebri�n Pag�e (Fenix)

/home/yawin/Documentos/Programación/BennuGD/tiempo/algo.prg:13: error: Library "mod_sound.so" not found ( token error: "mod_sound" ).
yawin@Tardis:~/Documentos/Programación/BennuGD/tiempo$ bgdc algo.prg
BGDC 1.0.0 (Nov 21 2012 18:57:53)
Bennu Game Development Compiler

Copyright (c) 2006-2012 SplinterGU (Fenix/BennuGD)
Copyright (c) 2002-2006 Fenix Team (Fenix)
Copyright (c) 1999-2002 Jos� Luis Cebri�n Pag�e (Fenix)

/home/yawin/Documentos/Programación/BennuGD/tiempo/algo.prg:13: error: Library "mod_sound.so" not found ( token error: "mod_sound" ).

La versión que he instalado es la descarga para Linux de la web. ¿Cómo instalo esas librerías que me faltan?
Sigue el desarrollo de mi motor RPG: https://www.youtube.com/watch?v=TbsDq3RHU7g

process main()
       begin
           loop
               pedo();
               frame;
            end
       end

alex

  • Sr. Member
  • ****
  • Mensajes: 262
  • Karma: 7
  • BENNUGD!!!
Re:Problemas con la compilación en Ubuntu 64bits
« Respuesta #1 en: Enero 11, 2013, 01:31:36 pm »
Que version del sh es??? yo tengo esa la version 307 en Ubuntu studio 64 bits tambien, y no me ha producido ningun error al compilar ese mismo ej del tiempo. Si usas esa creo que deberia ir bien.

alex

  • Sr. Member
  • ****
  • Mensajes: 262
  • Karma: 7
  • BENNUGD!!!
Re:Problemas con la compilación en Ubuntu 64bits
« Respuesta #2 en: Enero 11, 2013, 03:04:04 pm »
Se me habia olvidado que igual puede ser por alguna dependencia de la mod_sound, en ese caso colocate en la carpeta donde tengas instalado la mod_sound, y haces:

Código: [Seleccionar]
ldd mod_sound.so
La orden de ldd es para ver las dependencias, y en ese caso te debe dar en un error en alguna, en ese caso revisas si esta la libreria y si no falta es por alguna dependencia de esa libreria



Yawin

  • Hero Member
  • *****
  • Mensajes: 1088
  • Karma: 44
  • La primera persona que ha "demosceneado" en Bennu.
Re:Problemas con la compilación en Ubuntu 64bits
« Respuesta #3 en: Enero 11, 2013, 05:33:05 pm »
En la carpeta de librerías tengo "libmod_sound.so" que al hacerle "ldd" me devuelve lo siguiente:

Código: [Seleccionar]
    linux-gate.so.1 =>  (0xf77ca000)
    libbgload.so => /usr/local/share/bennugd/lib/libbgload.so (0xf77a1000)
    libbgdrtm.so => /usr/local/share/bennugd/lib/libbgdrtm.so (0xf7772000)
    libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf75c7000)
    libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf75c2000)
    libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0xf75a9000)
    libcrypto.so.1.0.0 => /lib/i386-linux-gnu/libcrypto.so.1.0.0 (0xf73fd000)
    libSDL_mixer-1.2.so.0 => not found
    libSDL-1.2.so.0 => /usr/lib/i386-linux-gnu/libSDL-1.2.so.0 (0xf7363000)
    libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf7348000)
    libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf731c000)
    /lib/ld-linux.so.2 (0xf77cb000)
    libasound.so.2 => /usr/lib/i386-linux-gnu/libasound.so.2 (0xf722a000)
    libpulse-simple.so.0 => /usr/lib/i386-linux-gnu/libpulse-simple.so.0 (0xf7225000)
    libpulse.so.0 => /usr/lib/i386-linux-gnu/libpulse.so.0 (0xf71d6000)
    libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xf70a0000)
    libXext.so.6 => /usr/lib/i386-linux-gnu/libXext.so.6 (0xf708e000)
    libcaca.so.0 => /usr/lib/i386-linux-gnu/libcaca.so.0 (0xf6fc2000)
    librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xf6fb9000)
    libpulsecommon-2.1.so => /usr/lib/i386-linux-gnu/pulseaudio/libpulsecommon-2.1.so (0xf6f54000)
    libjson.so.0 => /usr/lib/i386-linux-gnu/libjson.so.0 (0xf6f4a000)
    libdbus-1.so.3 => /lib/i386-linux-gnu/libdbus-1.so.3 (0xf6f00000)
    libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xf6ede000)
    libslang.so.2 => /lib/i386-linux-gnu/libslang.so.2 (0xf6daf000)
    libncursesw.so.5 => /lib/i386-linux-gnu/libncursesw.so.5 (0xf6d7d000)
    libtinfo.so.5 => /lib/i386-linux-gnu/libtinfo.so.5 (0xf6d5e000)
    libwrap.so.0 => /lib/i386-linux-gnu/libwrap.so.0 (0xf6d54000)
    libsndfile.so.1 => /usr/lib/i386-linux-gnu/libsndfile.so.1 (0xf6ce0000)
    libasyncns.so.0 => /usr/lib/i386-linux-gnu/libasyncns.so.0 (0xf6cd9000)
    libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xf6cd4000)
    libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xf6ccd000)
    libnsl.so.1 => /lib/i386-linux-gnu/libnsl.so.1 (0xf6cb3000)
    libFLAC.so.8 => /usr/lib/i386-linux-gnu/libFLAC.so.8 (0xf6c63000)
    libvorbisenc.so.2 => /usr/lib/i386-linux-gnu/libvorbisenc.so.2 (0xf6aeb000)
    libvorbis.so.0 => /usr/lib/i386-linux-gnu/libvorbis.so.0 (0xf6abe000)
    libogg.so.0 => /usr/lib/i386-linux-gnu/libogg.so.0 (0xf6ab6000)
    libresolv.so.2 => /lib/i386-linux-gnu/libresolv.so.2 (0xf6a9f000)

No veo errores.

p.d.: Acabo de ver el error xDD
« última modificación: Enero 11, 2013, 05:48:19 pm por Yawin »
Sigue el desarrollo de mi motor RPG: https://www.youtube.com/watch?v=TbsDq3RHU7g

process main()
       begin
           loop
               pedo();
               frame;
            end
       end

alex

  • Sr. Member
  • ****
  • Mensajes: 262
  • Karma: 7
  • BENNUGD!!!
Re:Problemas con la compilación en Ubuntu 64bits
« Respuesta #4 en: Enero 11, 2013, 05:37:54 pm »
parece que no tienes la SDLmixer instalada, yo para instalar las dependencias de bennu use el synaptic.

Yawin

  • Hero Member
  • *****
  • Mensajes: 1088
  • Karma: 44
  • La primera persona que ha "demosceneado" en Bennu.
Re:Problemas con la compilación en Ubuntu 64bits
« Respuesta #5 en: Enero 11, 2013, 05:47:45 pm »
He instalado la librería que falta y me sigue diciendo lo mismo. Creo que no era por la dependencia (que también), creo que simplemente no la encuentra. Yo he encontrado "libmod_sound.so" en "/usr/local/share/bennugd/lib". Igual en algún lugar debería de haber un... no se como se llama. Como un acceso directo, pero en Linux.
Sigue el desarrollo de mi motor RPG: https://www.youtube.com/watch?v=TbsDq3RHU7g

process main()
       begin
           loop
               pedo();
               frame;
            end
       end

alex

  • Sr. Member
  • ****
  • Mensajes: 262
  • Karma: 7
  • BENNUGD!!!
Re:Problemas con la compilación en Ubuntu 64bits
« Respuesta #6 en: Enero 11, 2013, 07:03:40 pm »
el instalador instala bien, no hay que hacer accesos directos (al menos yo no lo he hecho), debe ser por la dependencia creo yo, no se, que te dice ldd en libmod_sound.so???

Una cosa, que paquete te has bajado para 64 bits (que en sistemas de 64 bits no indica nada al lado del paquete en synaptic) o el de 32 bits (que en 64 bits te pone i386 al lado)??? Me da que puede que sea por eso, en ese caso te habria dado otra vez el mismo error haciendo ldd.

Yawin

  • Hero Member
  • *****
  • Mensajes: 1088
  • Karma: 44
  • La primera persona que ha "demosceneado" en Bennu.
Re:Problemas con la compilación en Ubuntu 64bits
« Respuesta #7 en: Enero 11, 2013, 10:31:47 pm »
He puesto: "apt-get install libsdl-mixer1.2" y ahora, no me da problemas de dependencias. Lo que me dice es "mod_sound.so not found" o sea que no encuentra la librería.
Sigue el desarrollo de mi motor RPG: https://www.youtube.com/watch?v=TbsDq3RHU7g

process main()
       begin
           loop
               pedo();
               frame;
            end
       end

alex

  • Sr. Member
  • ****
  • Mensajes: 262
  • Karma: 7
  • BENNUGD!!!
Re:Problemas con la compilación en Ubuntu 64bits
« Respuesta #8 en: Enero 11, 2013, 10:35:53 pm »
El problema es que no es eso, en 32 bits si, porque no hay que indicar nada mas, pero en 64 hay que indicar en caso de que no sea esa arquitectura. prueba "apt-get install libsdl-mixer1.2:i386" Creo que con eso deberia ir bien.
« última modificación: Enero 11, 2013, 10:37:35 pm por alex »

Yawin

  • Hero Member
  • *****
  • Mensajes: 1088
  • Karma: 44
  • La primera persona que ha "demosceneado" en Bennu.
Re:Problemas con la compilación en Ubuntu 64bits
« Respuesta #9 en: Enero 11, 2013, 10:49:46 pm »
Anda! Pues tenías razón. Dios, qué oxidadas tengo estas cosas. Muchas gracias. Siento ser tan cabezota.
Sigue el desarrollo de mi motor RPG: https://www.youtube.com/watch?v=TbsDq3RHU7g

process main()
       begin
           loop
               pedo();
               frame;
            end
       end