Autor Tema: Problema al copiar un fichero  (Leído 1380 veces)

Yawin

  • Hero Member
  • *****
  • Mensajes: 1091
  • Karma: 45
  • La primera persona que ha "demosceneado" en Bennu.
Problema al copiar un fichero
« en: Mayo 30, 2014, 09:18:24 pm »
Hola a todos!
Últimamente no me paso todo lo que debiera por aquí. Entre los trabajos de clase y los proyectos personales justo justo tengo tiempo para ivnertir en mi motor RPG.


El caso es que tengo un problema gordo: mi motor, tiene un botón que dice "Reiniciar partida". Lo que hace es borrar una base de datos sqlite y sustituirla por una copia de la original. Tal y como tiene que estar al inicio de la partida. Sí, lo se, es un poco rudimentario. Pero hasta hace escasas dos horas me funcionaba genial.


El caso es que, no entiendo por qué, ahora no funciona. Creo que es al copiarse, que se copia mal. En fin, este es el proyecto: http://pensarescompartir.com/MotorRPG.zip (pesa un pelín porque es la carpeta íntegra. No he borrado ni los logs).


La copia se hace en el fichero "/dll/escenas/menu.prg" a partir de la línea 162
La función de copiar está en el fichero "/dll/funciones/libfile.prg"


Si alguno entiende qué pasa, por favor, necesito vuestra ayuda.
Sigue el desarrollo de mi motor RPG: https://www.youtube.com/watch?v=TbsDq3RHU7g

process main()
       begin
           loop
               pedo();
               frame;
            end
       end

l1nk3rn3l

  • Hero Member
  • *****
  • Mensajes: 2014
  • Karma: 257

Yawin

  • Hero Member
  • *****
  • Mensajes: 1091
  • Karma: 45
  • La primera persona que ha "demosceneado" en Bennu.
Re:Problema al copiar un fichero
« Respuesta #2 en: Mayo 30, 2014, 11:12:33 pm »
No me has entendido xD
Yo copio el archivo. Tal cual. A pelo. Antes me iba; pero, derepente ha dejado de ir y no se por qué.
Sigue el desarrollo de mi motor RPG: https://www.youtube.com/watch?v=TbsDq3RHU7g

process main()
       begin
           loop
               pedo();
               frame;
            end
       end

l1nk3rn3l

  • Hero Member
  • *****
  • Mensajes: 2014
  • Karma: 257
Re:Problema al copiar un fichero
« Respuesta #3 en: Mayo 31, 2014, 12:25:24 am »
echaremos un vistazo

Yawin

  • Hero Member
  • *****
  • Mensajes: 1091
  • Karma: 45
  • La primera persona que ha "demosceneado" en Bennu.
Re:Problema al copiar un fichero
« Respuesta #4 en: Mayo 31, 2014, 09:25:54 am »
Creo que es un problema con la propia base de datos. Porque la misma función con una versión anterior de la base de datos sigue funcionando.


Actualización:
He detectado que de una tabla en la que tengo 23 columnas me ignora las últimas 6 columnas que he añadido. Creo que puede ser eso.


Actualización 2:
Comprobado, sqlite no maneja tablas tan grandes. Voy a tener que dividirla.
« última modificación: Mayo 31, 2014, 11:31:24 am por Yawin »
Sigue el desarrollo de mi motor RPG: https://www.youtube.com/watch?v=TbsDq3RHU7g

process main()
       begin
           loop
               pedo();
               frame;
            end
       end