Autor Tema: no me va el módulo de sonido de pixtudio.  (Leído 839 veces)

DCelso

  • Hero Member
  • *****
  • Mensajes: 3708
  • Karma: 181
no me va el módulo de sonido de pixtudio.
« en: Noviembre 15, 2016, 10:30:37 pm »
he usado el ultimo pixtudiopm para hacer un ejemplo de sonido, y resulta que va perfecto en el pc, pero lo paso a apk y lo isntalo en el móvil y al abrir el programa se cierra.

¿Qué puede ser?

Mas sencillo no puede ser.
Código: [Seleccionar]

import "mod_sound";

Global
    puntos;
    fuente;
  waves[2];
End

Begin
    set_mode(800,600);
    set_fps(60,0);
    fpg_load("general.fpg");
    fuente=fnt_load("texto.fnt");
  waves[1] = sound_load("1.wav");
  waves[2] = sound_load("2.wav");
  boton (200,300, 21, waves[1]);
  boton (300,300, 31, waves[2]);
  mouse.graph = 10;
    loop
        if(key(_esc) )
            exit();
        end
   
        frame;
    end
End

Process boton(x, y, graph, idwave);
Begin
    loop
   
        if(mouse.left)
            while (mouse.left) frame;end
      if (collision ( type mouse) )
        sound_play(idwave,0);
      end
        end
        frame;
    end
End
Monstruos Diabólicos

"A PAck of classic GAMEs For BennuGD" en desarrollo
http://code.google.com/p/apagame4be/

panreyes

  • Administrator
  • *****
  • Mensajes: 2233
  • Karma: 81
    • panreyes.com
Re:no me va el módulo de sonido de pixtudio.
« Respuesta #1 en: Noviembre 16, 2016, 12:12:51 am »
Culpa mía -_-'

Si has utilizado los binarios de PixTudioPM, no me he acordado de actualizar el port de Android -_-'

Aquí te lo he compilado con las libs de PixTudio actualizadas -> https://www.dropbox.com/s/wpvdvktnhx4mm4a/testwaves-1.0-android.apk?dl=0
« última modificación: Noviembre 16, 2016, 12:24:50 am por panreyes »

DCelso

  • Hero Member
  • *****
  • Mensajes: 3708
  • Karma: 181
Re:no me va el módulo de sonido de pixtudio.
« Respuesta #2 en: Noviembre 16, 2016, 05:44:02 am »
 ;D , no pasa res.
Monstruos Diabólicos

"A PAck of classic GAMEs For BennuGD" en desarrollo
http://code.google.com/p/apagame4be/

panreyes

  • Administrator
  • *****
  • Mensajes: 2233
  • Karma: 81
    • panreyes.com
Re:no me va el módulo de sonido de pixtudio.
« Respuesta #3 en: Noviembre 16, 2016, 09:28:21 am »
Sí que pasa (aunque algo bueno). Lo tengo en cuenta para hacer una versión de PixTudioPM autoactualizable, en vez de tener que descargar todo el monstruo entero cada vez.

alicesimu

  • Sr. Member
  • ****
  • Mensajes: 256
  • Karma: 2
Re:no me va el módulo de sonido de pixtudio.
« Respuesta #4 en: Noviembre 16, 2016, 12:04:53 pm »
Si jjejeje descargar el paquete entero de cientos de MB, es un poco fastidio solo para un pequeño fix de pocos kilobytes jjejjejeje

Se tendría que hacer un programa que recoge la actualización de un servidor, con todos los ficheros sin comprimir... Y solo se descargaría lo que es mas reciente o faltante para ti, de forma automática, debería haber un index de las versiones que hay y los ficheros/carpetas por descargar...

Algo así.