Bennu for Dreamcast upgrade by Indiket

Started by Ryo Suzuki, February 10, 2016, 04:37:29 PM

« previous - next »

0 Members and 1 Guest are viewing this topic.

Ryo Suzuki

Indiket from dreamcast.es released a new build of Bennu for Dreamcast a few months ago based on Colombians Developers' port.

It is compatible with KOS 2.x, and has been build with SDL 1.2.13, SDL_Mixer 1.2.12, libpng 1.6.18 and freetype 2.6. Can play MOD music again, and it has support for 2 pads. It includes the extra "mod_ttf" too (and even can play .ogg music files)

I was playing around a bit with it and is working much better than the old version from Colombians Dev friends.

You can grab it here:

http://www.dreamcast.es/news.php?readmore=745

And I wrote a little noob tutorial for starting in BennuGD & Dreamcast on my site (english google translation):

https://translate.google.es/translate?sl=es&tl=en&js=y&prev=_t&hl=es&ie=UTF-8&u=http%3A%2F%2Fwww.segasaturno.com%2Fportal%2Ftutorial-bennugd-de-indiket-para-dreamcast-vf19-vt8570.html&edit-text=

I was thinking could be interesting for you, because the new port has not had much impact here and perhaps you don't know about it.


swamprocker

I'd really like to use it, but I can't get my game to boot on the Dreamcast. This is what I posted at dreamcast.es... maybe you can help...?

"I can get my game to compile and run in BennuGD (with a couple of bugs; a holdover from Fenix that I'm sure I can fix). Unfortunately, I cannot get the game to boot in the Dreamcast. I've tried everything, even looking at the source code for the games posted here, compiling with the -D flag set to "macro=DREAMCAST" and making sure all of my paths and filenames are correct, but I get nothing but a black screen. Another unfortunate thing is that I cannot test my code using multisession CDs, so I'll have to set up an emulator for testing.... IF I can get my game to run on the Dreamcast. It runs fine using the old Fenix 0.84b runtime, so I'm at a loss as to why it doesn't work under BennuGD.

Any suggestions that may help would be greatly appreciated. Thanks!"

l1nk3rn3l

#2



download "caza muertos test example" include a readme...

more
examples
here

https://sourceforge.net/projects/coldev/files/Dreamcast/

powerfull video tutorial

https://www.youtube.com/watch?v=O-7oaifbSDI

swamprocker

#3
I did try all of that before, but still no luck. My next step is to remove music files to see if I'm overloading the memory somehow...

EDIT: Well, I figured out that the compiler is corrupting the DCB somehow, so I reinstalled Tools 2.2. Seems to work fine now.