Autor Tema: PROBLEMA CON EL INTERPRETE (BGDI) DE BENNUGD!  (Leído 466 veces)

Tayura_TT

  • Newbie
  • *
  • Mensajes: 13
  • Karma: 0
  • De todo un poco a la vida...
    • Mi Canal de Youtube
PROBLEMA CON EL INTERPRETE (BGDI) DE BENNUGD!
« en: Diciembre 11, 2017, 11:58:47 am »
Saludos comunidad del foro de Bennu, hace un tiempo que no acudía por su ayuda jaja, esta vez tengo el siguiente problema... Llevo aproximadamente 3 semanas sin tocar Bennu (por cuestiones de trabajo) y ayer disponia de un tiempo libre que quise aprovechar para continuar con el juego que estoy creando, sin embargo apenas abrí el IDE y presione f6 me apareció el siguiente mensaje de error...



Lo mas curioso es que no se trata de un error en el código del juego, pues probé intentando abrir algunos de los juegos de ejemplo que descargue de bennu y todos me dan el mismo error.

Desconozco totalmente el porque de esto o que eh hecho mal y mas porque no eh alterado nada desde la ultima vez que ejecute bennu. Pues todo antes me iba de maravilla.

Espero tengan la solución a este problema y me puedan ayudar, eso es todo y que tengan un buen dia.
« última modificación: Diciembre 11, 2017, 12:01:49 pm por KyouyaL »
Trabajos Actuales: "Proyecto Chizuru" y "Hoppy Bat"

FreeYourMind

  • Hero Member
  • *****
  • Mensajes: 5598
  • Karma: 127
    • GECA soft
Re:PROBLEMA CON EL INTERPRETE (BGDI) DE BENNUGD!
« Respuesta #1 en: Diciembre 11, 2017, 02:29:35 pm »
Seguramente the falte alguna dll, o tengas versiones erroneas (de la zlib por ejemlo), prueba a descargar la ultima version de bennu en una carpeta limpia, copias los archivos de tu codigo y compilas de nuevo

panreyes

  • Administrator
  • *****
  • Mensajes: 2100
  • Karma: 70
    • panreyes.com
Re:PROBLEMA CON EL INTERPRETE (BGDI) DE BENNUGD!
« Respuesta #2 en: Diciembre 11, 2017, 04:25:25 pm »
Prueba a ejecutar bgdi desde la consola de comandos, a ver si ahí te aparece algo más de información.

l1nk3rn3l

  • Hero Member
  • *****
  • Mensajes: 1990
  • Karma: 256
Re:PROBLEMA CON EL INTERPRETE (BGDI) DE BENNUGD!
« Respuesta #3 en: Diciembre 11, 2017, 04:45:15 pm »
=================
Posibles soluciones:
=================

1. Intenta descargando el compilador de :

http://www.bennugd.org/node/2

2. desactiva el Antivirus .. y vuelve a instalar todo el bennu

3. instala el directx
https://www.microsoft.com/es-ES/download/details.aspx?id=35


//soluciones extremas:

4. reinicia en modo seguro y pruebalo en este entorno...

5. pruebalo desde una maquina virtual (te evitas reinstalar el S.O.)
https://www.virtualbox.org/wiki/Downloads






« última modificación: Diciembre 11, 2017, 11:04:27 pm por l1nk3rn3l »

Drumpi

  • Hero Member
  • *****
  • Mensajes: 6241
  • Karma: 157
  • Odio el periodo "entre proyectos"
    • La web de Drumpi
Re:PROBLEMA CON EL INTERPRETE (BGDI) DE BENNUGD!
« Respuesta #4 en: Diciembre 12, 2017, 12:42:34 am »
O puedes probar a activar el modo de compatibilidad con windows anteriores. ¿Has actualizado el sistema desde la última vez que ejecutaste Bennu?
Hala, como con 1001 procesos sólo va a 9 FPS, vamos a meterle 32 veces más, a ver si revienta.
(Drumpi epic moment)

Tayura_TT

  • Newbie
  • *
  • Mensajes: 13
  • Karma: 0
  • De todo un poco a la vida...
    • Mi Canal de Youtube
Re:PROBLEMA CON EL INTERPRETE (BGDI) DE BENNUGD!
« Respuesta #5 en: Diciembre 12, 2017, 03:08:44 am »
Les cuento lo que eh hecho hasta ahora...

1) Primeramente me fui por lo que creí mas lógico y facil, descargar la ultima versión del bennupack (la 2.9) pues la versión que yo tenia era la 2.7 Lamentablemente esto no resulto, me sigue dando el mismo error independientemente de que sea la 2.9 o 2.7

2) Luego de eso probé descargando Bennu directamente de la web oficial, descargando la versión de Windos (que si no me equivoco es el archivo bgd-1.0.0-r342-win32.exe) descargue tanto el ejecutable .exe como el archivo .rar esto tampoco me funciono. Como dato curioso, el ejecutable nunca me arranco y cuando lo hacia aparecía la ventana negra tipo cmd y apto seguido el error del interprete que antes mostré, y con respecto al archivo rar al remplazar su contenido con el que yacía dentro de la carpeta bin del bennupack, este ni siquiera compilaba al oprimir f6 (nose si hice algo mal o que xd, corrijan me si es así)

3) probé cambiando la compatibilidad en las propiedades del BGDI, probé con cada versión de windows anterior, y ninguna me funciona.

4)Intente descargando el directX y mas de lo mismo, sin solución D:

Me falta probar alguna de las otras ideas que han ofrecido y esperar que una de esas me solucione el problema...

Y respondiendo a la pregunta de Drumpi, a decir verdad no te sabría decir con certeza si ha habido alguna actualización a lo largo de estas semanas, pero la versión de windows que tengo es la 10 y normalmente suele estar actualizandose, es muy probable que haya habido una actualización y de allí que se produzca este error. Porque como eh dicho antes, no eh tocado nada de bennu desde hace semanas hasta ayer que me tope con este problemilla.

En todo caso agradezco su ayuda y sigan aportando posibles soluciones, intentare hasta que pueda de nuevo volver a programar en bennu.
Trabajos Actuales: "Proyecto Chizuru" y "Hoppy Bat"

SplinterGU

  • Hero Member
  • *****
  • Mensajes: 12704
  • Karma: 374
Re:PROBLEMA CON EL INTERPRETE (BGDI) DE BENNUGD!
« Respuesta #6 en: Diciembre 12, 2017, 04:33:59 am »
prueba desde consola, sin el IDE.
Download Lastest BennuGD Release: http://www.bennugd.org/node/2

Drumpi

  • Hero Member
  • *****
  • Mensajes: 6241
  • Karma: 157
  • Odio el periodo "entre proyectos"
    • La web de Drumpi
Re:PROBLEMA CON EL INTERPRETE (BGDI) DE BENNUGD!
« Respuesta #7 en: Diciembre 13, 2017, 12:30:41 am »
Es que es raro: Bennu funciona por software, funciona hasta en una lavadora si esta tiene pantalla y SDL.
No sé, ya incluso probaría en modo a prueba de fallos, a ver si es de alguna librería externa o es cosa del propio windows, que se ha vuelto quisquilloso el 10. De momento, no hemos recibido notificaciones de problemas con él.

Te diría, como último recurso, que intentases compilar Bennu en tu máquina. Puede que en alguna actualización se haya introducido una incompatibilidad en Windows con programas anteriores. Habría que investigar si se han dado más casos.

Al menos parece que el compilador funciona.
Hala, como con 1001 procesos sólo va a 9 FPS, vamos a meterle 32 veces más, a ver si revienta.
(Drumpi epic moment)

Tayura_TT

  • Newbie
  • *
  • Mensajes: 13
  • Karma: 0
  • De todo un poco a la vida...
    • Mi Canal de Youtube
Re:PROBLEMA CON EL INTERPRETE (BGDI) DE BENNUGD!
« Respuesta #8 en: Diciembre 14, 2017, 11:02:28 am »
Saludos Foro de Bennu, desde ayer ya puedo volver a programar en Bennu!  ;D Pero claro esta, diré como es que lo eh logrado, en dado caso algún otro usuario sufra este mismo problema.

Nose que tan "Solución" sea lo que hice pues tuve retroceder a la versión 2.6 de Bennu y lo correcto seria que las versiones actuales me corran pero esto ha sido lo único que me ha funcionado... La única diferencia aparente entre las versiones que probé previamente (2.7 y 2.9) con respecto a la 2.6 es que esta ultima no es portable, sino que requiere ser instalado el setup en el equipo.

Porque razón solo me funciona así, ni puta idea xD pero es bastante curioso (Mas porque fue de un momento a otro que dejo de correr la 2.7)... Sin embargo dudo que se trata de bennu el problema, ya que me tome la tarea de instalar el bennupack 2.9 y 2.7 en las otras dos PC que hay en mi casa (Una es una PC de escritorio con windows 10 y la otra una laptop windows 7) y ambas si ejecutaban estas versiones sin ningún problema, la única que les agarro maña es la netbook (que es donde actualmente uso bennu para mi juego).

A lo que puedo concluir es que el problema yace en mi netbook, dedo decir que ya lleva sus añitos encima y seguro que algo por ahi es que jode. En todo caso la version 2.6 me basta y sobra para lo que quiero hacer.

Moraleja...Si abandonas tu juego, toca castigo  :P
Trabajos Actuales: "Proyecto Chizuru" y "Hoppy Bat"

panreyes

  • Administrator
  • *****
  • Mensajes: 2100
  • Karma: 70
    • panreyes.com
Re:PROBLEMA CON EL INTERPRETE (BGDI) DE BENNUGD!
« Respuesta #9 en: Diciembre 14, 2017, 12:48:35 pm »
Gracias por compartir tu solución Tayura_TT.

De todas formas, debes saber y recordar que BennuPack no es exactamente BennuGD, sino que es un pack de herramientas que lleva BennuGD.

Probablemente el problema no estaba en BennuGD, sino en el pack. Por eso te recomendábamos SplinterGU y yo que intentases ejecutar el juego desde la consola de comandos. Si no sabes utilizar la consola, te recomiendo que aprendas ya que te será muy útil (o incluso necesario) en muchísimas tareas relacionadas con programación.

SplinterGU

  • Hero Member
  • *****
  • Mensajes: 12704
  • Karma: 374
Re:PROBLEMA CON EL INTERPRETE (BGDI) DE BENNUGD!
« Respuesta #10 en: Diciembre 14, 2017, 01:42:02 pm »
Saludos Foro de Bennu, desde ayer ya puedo volver a programar en Bennu!  ;D Pero claro esta, diré como es que lo eh logrado, en dado caso algún otro usuario sufra este mismo problema.

Nose que tan "Solución" sea lo que hice pues tuve retroceder a la versión 2.6 de Bennu y lo correcto seria que las versiones actuales me corran pero esto ha sido lo único que me ha funcionado... La única diferencia aparente entre las versiones que probé previamente (2.7 y 2.9) con respecto a la 2.6 es que esta ultima no es portable, sino que requiere ser instalado el setup en el equipo.

Porque razón solo me funciona así, ni puta idea xD pero es bastante curioso (Mas porque fue de un momento a otro que dejo de correr la 2.7)... Sin embargo dudo que se trata de bennu el problema, ya que me tome la tarea de instalar el bennupack 2.9 y 2.7 en las otras dos PC que hay en mi casa (Una es una PC de escritorio con windows 10 y la otra una laptop windows 7) y ambas si ejecutaban estas versiones sin ningún problema, la única que les agarro maña es la netbook (que es donde actualmente uso bennu para mi juego).

A lo que puedo concluir es que el problema yace en mi netbook, dedo decir que ya lleva sus añitos encima y seguro que algo por ahi es que jode. En todo caso la version 2.6 me basta y sobra para lo que quiero hacer.

Moraleja...Si abandonas tu juego, toca castigo  :P

version 2.6, setup? yo no libere nunca una version 2.6 de bennugd... quizas te referis a bennupack... por que no probas con la oficial?
Download Lastest BennuGD Release: http://www.bennugd.org/node/2

gecko

  • Hero Member
  • *****
  • Mensajes: 801
  • Karma: 47
    • Torres Baldi Studio
Re:PROBLEMA CON EL INTERPRETE (BGDI) DE BENNUGD!
« Respuesta #11 en: Diciembre 14, 2017, 05:26:59 pm »
Eso que hablas de 2.6 es la version de Bennupack, que es un conjunto de herramientas "alrededor" de bennugd que ayudan o simplifican el inicio.

Pero el "nucleo", lo que está debajo de todo es BennuGD. Cuando te sugirieron intentar ejecutar los juegos por consola, por linea de comandos, era justamente para poder saber si el problema es del lado de bennugd, o si el problema viene en alguna parte del bennupack.

Aunque solo tengas pensado usar el bennupack con todo ya configurado, es importante que entiendas estas diferencias, porque te van a ayudar (y a nosotros tambien) a identificar el origen de los problemas, y eso hace que muchas veces sea mas sencillo encontrar la solución.

Me alegro que puedas tener ahora mismo una version del BennuPack funcionando, pero lo mejor sería identificar la causa del problema original, así por ejemplo, si se puede corregir en una futura versión del BennuPack o en el mismo BennuGD, eso sería un beneficio para todos.
Torres Baldi Studio
http://torresbaldi.com

Tayura_TT

  • Newbie
  • *
  • Mensajes: 13
  • Karma: 0
  • De todo un poco a la vida...
    • Mi Canal de Youtube
Re:PROBLEMA CON EL INTERPRETE (BGDI) DE BENNUGD!
« Respuesta #12 en: Diciembre 17, 2017, 08:05:26 pm »
Oh vale! ya comprendo ahora, es bueno que me corrijan con esto, pues hasta ahora creí que el BennuPack era como tal BennuGD.

Con respecto a lo de la consola desconozco totalmente como ejecutarlos juegos desde esta, de allí que no intentara lo dicho por Splinter. Pero seguiré sus consejos aprovechare ahora mismo (que tengo tiempo libre) para informarme mas y presupuesto compartir acá mi resultado por si alguien a futuro lo necesita.

Sin mas agradezco nuevamente su ayuda y orientación, pues a fin de cuenta acá estoy para aprender jaja y adentrarme poco a poco en esto de bennu y el desarrollo de videojuegos.  ;D

« última modificación: Diciembre 17, 2017, 08:08:25 pm por Tayura_TT »
Trabajos Actuales: "Proyecto Chizuru" y "Hoppy Bat"