Bennu Game Development

English Forums => Helpdesk => Mensaje iniciado por: raverdave en Noviembre 26, 2008, 10:02:57 pm

Título: Compile success but run failure!!
Publicado por: raverdave en Noviembre 26, 2008, 10:02:57 pm
I have just tried compiling this example in bennu under linux,specifically kubuntu!

Código: [Seleccionar]
import "mod_map"

Process main()
Begin
load_fpg("test.fpg");
ship(320,240,1);

Loop
frame;
end
end

Process ship(x,y,graph)
Begin
Loop
frame;
End
End

This compiles ok, but when i run the outputted .dcb file i get this:

root@RaverDave:/home/david/Desktop/tester# bgdi tester.dcb
No protocol specified
No protocol specified

     =======================|  DirectFB 1.0.1  |=======================
          (c) 2001-2007  The DirectFB Organization (directfb.org)
          (c) 2000-2004  Convergence (integrated media) GmbH
        ------------------------------------------------------------

(*) DirectFB/Core: Single Application Core. (2008-04-08 15:15)
(!) Direct/Modules: Unable to dlopen `/usr/lib/directfb-1.0-0/systems/libdirectfb_fbdev.so'!
    --> /usr/lib/directfb-1.0-0/systems/libdirectfb_fbdev.so: wrong ELF class: ELFCLASS64
(!) DirectFB/core/system: No system found!
No protocol specified
No protocol specified

     =======================|  DirectFB 1.0.1  |=======================
          (c) 2001-2007  The DirectFB Organization (directfb.org)
          (c) 2000-2004  Convergence (integrated media) GmbH
        ------------------------------------------------------------

(*) DirectFB/Core: Single Application Core. (2008-04-08 15:15)
(!) DirectFB/core/system: No system found!

Any help is greatly appreciated..thanks
Título: Re: Compile success but run failure!!
Publicado por: SplinterGU en Noviembre 26, 2008, 10:29:49 pm
http://www.google.com.ar/search?hl=es&q=DirectFB%2Fcore%2Fsystem%3A+No+system+found%21&btnG=Buscar+con+Google&meta=
Título: Re: Compile success but run failure!!
Publicado por: raverdave en Noviembre 27, 2008, 12:37:42 am
ok, after setting the frame buffer in the bios to manual, well maybe it did something,maybe not, also i typed sudo apt-get install fbset in the konsole,again maybe it did something..but along the way...


SUCCESS!!

yes I have successfully compiled and ran my first bennu program!
As you can see:

(http://i36.tinypic.com/3467t6e.png)
Título: Re: Compile success but run failure!!
Publicado por: SplinterGU en Noviembre 27, 2008, 05:27:18 am
cool!

:)
Título: Re: Compile success but run failure!!
Publicado por: Treval en Diciembre 23, 2008, 04:51:13 pm
How cute. =O

Treval aka Badman