bennugd linux

Started by SplinterGU, June 09, 2011, 11:30:00 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


we have problems with linux version in the server... linux version can be downloaded here ->
Download Lastest BennuGD Release:


There seems to be an error in the file, it doesn't work on ubuntu.
Torres Baldi Studio


maybe you need openssl 1.0.
Download Lastest BennuGD Release:


I went to .. and added ubuntu repo, after that i quit then rerun package manager and ticked everything bennu wise to install.. worked ok for me, i also found that this time after installing the newest kubuntu instead of ubuntu this time... , then installing gnome within Kubuntu and booting up into that, i can use kate fully with the terminal working, and not have to use KDE (which i find kinda sucks) and found that sdl and everything was already installed!! .... which is handy!


Good work with the script SplinterGU, the download is ready for get BennuGD in Linux another time :D
I have a issue in the execution of bgdc/bgdi in my Ubuntu x64. There isn't for x86 in my system. I can solve this problem looking for the libs in the network and i have uploaded a file with the libcrypto for x86:
Download it and extract, then, copy the files in /usr/lib32/ and enjoy BennuGD another time!! :D


Thanks for sharing with us :)


It is my pleasure.
I think there is a article in the wiki explaining this issue. I'll work in it.


Sorry for the delay.

I've installed bennu correcly now. (just following the wiki instructions :P )

Now when i try to run bennu, it says:
bgdc: error while loading shared libraries: cannot open shared object file: No such file or directory

I've tried to install openssl and says its already installed and in the most recent version. Any suggestion?

Torres Baldi Studio


Which Ubunu version are you using?
Try installing libssl0.9.8


Gecko, the first thing you need to know is if you are using a 32 bits OS or a 64bits OS, then, you must to looking for the /usr/lib/ directory with the sudo command. If you use a 64bits OS, the directory what you must fount is /usr/lib32/.
When you find the directory mentioned before, you must download the file and extract it, then, copy the file to the directory /usr/lib/ or /usr/lib32/
To do this step, you must open a console and write: 'sudo nautilus' without the ' simbol, then, a window of the file explorer must be opened, but is in the directory /root/ . Go up once and go into home folder, then, your user and your download folder, copy the files extracted before in the directory before mentioned.
Now, BennuGD must work properly.
Splinter, I think I can modify the script to install automatically the


Also, if you're in 32 bits Ubuntu you can just use my PPA too, it installs all the required dependencies.


I was trying on an old ubuntu, then i also tried on debian (i was just testing, not using them for now).

Now, i will try with the last ubuntu. Thanks for the help, i'll let you know if it works.
Torres Baldi Studio


Try the repository. The files I uploaded don't work.


The filas i uploaded works, but you need to copy in the /lib32/ directory at hhd's root...



this solved my problem of executing it under Linux Mint 10. However when I compile or execute the compiler or the interpreter I get a message such as:

bgdi: /usr/lib32/ no version information available (required by /usr/lib32/bgd/lib/

Even tough it works.

Do you why I get this message?

My sites:
Smart Fpg Editor - Painless FPG Edition for Bennu and PixTudio
fenixlib - .NET support for manipulating PixTudio, Bennu and Div graphic formats